Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - PEC - Inconsistência na finalização da contagem de estoque com emissão de NF.



Ocorrência
No módulo Auto-Peças, ao tentar finalizar a contagem de estoque OFIPM040 com emissão de NF, o sistema apresenta a inconsistência abaixo:

: Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'VPG_FORNEC'.
Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'VPG_LOJA'.
Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'VPG_NUMPED'.
Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'VPG_NFIENT'.
Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'VPG_SERENT'.
Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'VPG_FORNEC'.
Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'VPG_LOJA'.

Ambiente
Protheus – Auto-Peças – A partir da versão 12.1.07

Causa
Esse incidente ocorre, pois não existe os campos abaixo no banco de dados e no dicionário de dados!

 'VPG_FORNEC'.
'VPG_LOJA'.
'VPG_NUMPED'.
 'VPG_NFIENT'.
'VPG_SERENT'.
'VPG_FORNEC'.
'VPG_LOJA'.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse o link https://tdn.totvs.com/pages/releaseview.action?pageId=521135843

2. Aplique a patch que consta no link acima;

Importante: Antes de aplicar a patch, realize o backup do RPO!

3. Crie os campos que consta na documentação do link https://tdn.totvs.com/pages/releaseview.action?pageId=498696551 , e siga as orientações que nela consta. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _