Ocorrência
Ao tentar utilizar o SmartECF, ocorre o erro da porta de comunicação do SAT.
Ambiente
Gemco Anywhere - SmartECF - a partir da versão 41.
Causa
Esse incidente ocorre por erro de configuração e BemaSAT.dll/SAT.dll incorretas.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Verifique na pasta do seu Sistema Operacional, System32 ou SysWOW64, se contém os arquivos BemaSAT.xml, BemaSAT.dll e SAT.dll:

2. Realize um teste utilizando o Activation Software, realizando uma consulta:
3. A consulta deverá retornar status OK. Acesse a pasta do programa, e copie o SAT.dll da mesma:
4. Cole na pasta do seu Sistema Operacional (System32 ou SysWOW64);
5. Confirme no seu arquivo BemaSAT.xml que as informações estão corretas e de acordo com o seu Gerenciador de dispositivos, apontando a porta do SAT e coloque na sua pasta do seu Sistema Operacional (System32 ou SysWOW64): 
6. Realize novo teste, o SmartECF irá abrir sem erros.
0 Comentários