Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

GA - SMARTECF - SAT - Erro de comunicação com a porta

Ocorrência
Ao tentar utilizar o SmartECF, ocorre o erro da porta de comunicação do SAT.

Ambiente
Gemco Anywhere - SmartECF - a partir da versão 41.

Causa
Esse incidente ocorre por erro de configuração e BemaSAT.dll/SAT.dll incorretas.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Verifique na pasta do seu Sistema Operacional, System32 ou SysWOW64, se contém os arquivos BemaSAT.xml, BemaSAT.dll e SAT.dll:
mceclip0.png
mceclip1.png

 

 

2. Realize um teste utilizando o Activation Software, realizando uma consulta:
mceclip4.png

 

3. A consulta deverá retornar status OK. Acesse a pasta do programa, e copie o SAT.dll da mesma:
mceclip3.png

 

4. Cole na pasta do seu Sistema Operacional (System32 ou SysWOW64);

 

5. Confirme no seu arquivo BemaSAT.xml que as informações estão corretas e de acordo com o seu Gerenciador de dispositivos, apontando a porta do SAT e coloque na sua pasta do seu Sistema Operacional (System32 ou SysWOW64)
mceclip2.png

 

6. Realize novo teste, o SmartECF irá abrir sem erros. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _