Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP-CRM -array out of bounds -0 of 13 - on TK61ENTGET

Ocorrência
Ao tentar incluir um membro a lista de marketing no Sigacrm, ocorre o erro:

array out of bounds ( 0 of 13 ) on TK61ENTGET(TMKA061.PRW) 07/05/2018 09:27:43 line : 2138

Ambiente

Microsiga Protheus - a partir da versão 12.

Causa

Quando o error.log é referente array out of bounds ( 0 of 13 ), significa que algum campo não esta como Usado ou o nível esta diferente de 1

Neste caso, o sistema não está encontrando o campo da tabela SU6U6_DENTIDA, que pode estar sem marcação de uso ou ter o seu nível diferente de 1.

Este array contempla os campos:

"U6_CODENT" } ) // Codigo Entidade
"U6_DESCENT" } ) // Nome Entidade
"U6_CODIGO" } ) // Codigo do Item
"U6_DATA" } ) // Data
"U6_ENTIDA" } ) // Entidade Selecionada
"U6_HRFIM" } ) // Hora Final
"U6_HRINI" } ) // Hora Inicio
"U6_CONTATO" } ) // Codigo Contato
"U6_NCONTAT" } ) // Nome Contato
"U6_DENTIDA" } ) // Descrição da Entidade

Qualquer e ero relacionado a array out of bounds na função TK61ENTGET, deverá ser validado se os campos acima estão como usado e com o nível.

Solução

Via SIGACFG , e busque a tabela SU6 e deixe o campo U6_DENTIDA como Usado e Nível como 1.
Após isso, reinicie o Smartclient e realize um novo teste.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _