FAQs - Suporte técnico

RH - Linha Protheus - PON - Ao efetuar a troca de turno, o cadastro do funcionário não é atualizado

Ocorrência
Ao efetuar a troca de turno, o cadastro do funcionário não é atualizado.

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - Todas as versões

Causa
Esse incidente ocorre se a data da Troca de Turno estiver fora do período de apontamento ativo, ou nos casos em que o cliente utiliza apenas o SIGAGPE e não tem integração com o Ponto, existe configuração incorreta de parâmetro ou divergências na troca de turno.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Para que o sistema efetive a troca no cadastro de funcionário, a data da troca de turno deve estar dentro do seu período aberto do ponto, definido no MV_PONMES. Se estiver fora do período, só atualizará o cadastro de funcionário após o fechamento.

2. Se não utiliza o módulo SIGAPON, basta deixar o parâmetro MV_PONMES sem conteúdo, ou seja, em branco, e realize a troca novamente que será atualizado no cadastro do funcionário.

3. No turno de trabalho aba informações ponto, parâmetro Turno Opc. (R6_TNOOPC) deve ser informado um turno de trabalho diferente, informar o mesmo turno gera erro. 

4. Quando é efetuado a troca de turno os parâmetros que devem ser alterados são os Turno Para (PF_TURNOPA), Seq. Para (PF_SEQUEPA) e Regra Para (PF_REGRAPA). O sistema deve preservar nos parâmetros Turno De (PF_TURNODE), Seq. De (PF_SEQUEDE) e Regra De (PF_REGRADE) o conteúdo da ultima troca efetuada.

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Saiba mais:

RH - Linha Protheus - PON - Período de apontamento desconfigurado. Como configurar: MV_PAPONTA e MV_PONMES

 

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