FAQs - Suporte técnico

RH - Linha Protheus - GPE - eSocial - S-2299 - Verbas não são integradas com o TAF

Ocorrência
S-2299 - Verbas não enviadas no evento devido erro de estrutura das tabelas. O evento S-2299 é enviado ao TAF com identificador do pagamento, informações de lotação tributária, mas sem Verbas/Rubricas. 

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal – Todas as versões

Causa
O erro ocorre devido divergência do tamanho dos campos nas tabelas envolvidas, em alguns casos está com tamanho igual no dicionário, mas no banco de dados está divergente.
Verifique no dicionário (SX3) o tamanho dos campos das tabelas envolvidas no processo e se o tamanho dessas tabelas no Banco de Dados estão idênticos.
Um exemplo que verificamos no suporte é que ao consultar o dicionário (SX3) os campos RR_CC, RD_CC e CTT_CUSTO estão todos com o mesmo tamanho de acordo com o definido no Grupo de campos (X3_GRPSXG = 004).

mceclip1.png

Mas ao consultar a Estrutura da tabela no Banco de Dados verificamos que uma das tabelas está com um campo de tamanho diferente ao do definido na SX3.

*Print do RD_CC com tamanho diferente da SX3.
mceclip2.png

*Print do RR_CC com tamanho igual ao da SX3.

mceclip3.png​​

O tamanho só estará diferente uma vez que a alteração não é realizada via configurador, ou seja, o grupo de campos não é ajustado automaticamente.

Solução
Orientação para analista Totvs.
O tamanho de campo deverá ser o mesmo no dicionário (SX3) e no banco de dados.

Observação: Os ajustes no tamanho dos campos deverão ser realizados sempre via SIGACFG (configurador) e quando houver mais de uma tabela envolvida para o mesmo campo, realizar a alteração pelo grupo de campos. 

Em caso de dúvidas para realizar os ajustes em seu ambiente, consulte o seu Gerente de Contas para solicitar um analista "in loco".

Saiba Mais
Para saber mais consulte os links abaixo: 
S-2299 - Ao calcular uma rescisão o sistema envia os dados para o TAF no evento S-2299 porem as verbas (rubricas) do calculo não são geradas
eSocial | Protheus - Entregas Legais
MOS - Manual de Orientação eSocial
Perguntas Frequentes site eSocial 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _