Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Erro ao conectar em servidor de e-mail utilizando os protocolos SMTP, POP3 ou IMAP

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência

Ao tentar conectar em um servidor de e-mail utilizando os protocolos SMTP, POP3 ou IMAP é gerado erro abaixo:

Erro de conexão: Aborted by User


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 11.8

Causa
Este erro ocorre porque a classe TMailManager() tenta realizar a conexão por meio dos protocolos acima listados com a versão SSL incorreta.

Solução
Adicionar a chave SSLVERSION na seção MAIL do arquivo *.INI do Application Server.

Observação
É necessário que as permissões de conexão para os protocolos desejados esteja habilitada em seu servidor de e-mail.

Saiba mais
Correção - TMailManager não conecta em contas do Office 365
SSLVersion

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

2 Comentários

  • Avatar
    JONATHAN WILLIAN INACIO GOMES

    Pra mim isso não adiantou, estou com esse problema, fiz testes alternando o valor dessa chave e não mudou nada.

    -1
    Ações de comentário Permalink
  • Avatar
    Guilherme Bigois

    JONATHAN WILLIAN INACIO GOMES, por gentileza efetue a abertura de um ticket pontual para o time Protheus ADVPL.

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _