FAQs - Suporte técnico

Framework - Linha Datasul - TEC - Lock exclusivo para aplicação do delta via Console de Atualização

time.png Tempo aproximado para leitura: 00:00:40 min

Ocorrência
Atualização de dicionário via Console de Atualização apresenta a mensagem Lock wait timeout de 1800 segundos expirado. (8812)

Ambiente
Framework - Framework (Linha Datasul) - Instalação / Atualização - Todas as versões

Causa
Indica que o Progress aguardou por 30 segundos para adquirir um lock exclusivo para aplicação do delta, porém, outro processo estava acessando o banco.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Confirme que o JBOSS e o serviço Appserver, estão parados;
2. Estando os dois parados, pelo proenv, no servidor do banco de dados, execute o comando proshut banco;
3. Veja se aparece algum outro usuário conectado no banco, além do Console de Atualização. Caso sim, veja quem é o usuário e mande finalizar a sessão;
4. Confirmando que não existem outros usuários conectados no banco, retorne o backup dos bancos antes de iniciar a atualização e refaça o processo.

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