Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP-CRM-InterFunctionCall -cannot find function FT300NUM

Ocorrência

Ao clicar no botão incluir da Oportunidade de Vendas (FATA300), ocorre o erro:

InterFunctionCall: cannot find function FT300NUM in AppMap on {|a,b,c| FWInitCpo(a,b,c),xRet:=(FT300NUM()),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }(PROTHEUSFUNCTIONMVC.PRX) 10/04/2019 14:27:48

Ambiente

Microsiga Protheus - a partir da versão 12.

Causa

O problema ocorre por que existe uma validação indevida FT300NUM está  em das colunas da SX3 (  X3_When, x3_relação, x3_vlduser ou x3_valid) do campo AD1_NROPOR .


Solução

Para correção deste erro, retire a validação FT300NUM que encontra-se em uma das colunas da sx3 (  x3_when, x3_relação, x3_vlduser ou x3_valid) do campo AD1_NROPOR ,e desta forma, o erro deixará de ocorrer.

Obs: No padrão do sistema apenas o x3_valid  e x3_relação possuem validação, conforme abaixo, as demais colunas de validação do sx3 estão em branco:

x3_valid (validação de sistema): ExistChav("AD1")                                                                                                                
x3_relação(inicializador padrão): GetSxeNum("AD1","AD1_NROPOR")                                                                                                  

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _