Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - SIGACRM - Erro no inicializador de AD2_NOMVEN

time.png Tempo aproximado para leitura: 00:04:00 min

Ocorrência
Ao alterar a oportunidade de venda, gerou o erro: 

variable does not exist ACOLS on {|a,b,c| FWInitCpo(a,b,c),xRet:=(If(!INCLUI,Posicione("SA3",1,xFilial("SA3")+GDFieldGet("AD2_VEND", Len( aCols ) ),"A3_NOME"),""))

 

Ambiente
Cross Segmentos - Backoffice Protheus - SIGACRM - A partir da release 12

Causa
O erro ocorre por que o  x3_relação (inicializador padrão) do campo AD2_NOMVEN, está incorreto.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Acesse o configurador, Dicionário, Base de dados, e selecione a tabela AD2;
2. Ajuste o inicializador padrão do campo AD2_NOMVEN para IIF(!INCLUI,POSICIONE("SA3",1,XFILIAL("SA3")+AD2->AD2_VEND,"A3_NOME"),"");
3. Salve o campo, salve a tabela e atualize o dicionário de dados.

 

Altera__o_da_AD2_NOMVEN.gif

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _