Tempo aproximado para leitura: 00:01:12 min
Ocorrência
Ao executar uma aplicação Progress ou DBAccess é retornado o erro Could not load Oracle library oci.dll
Ambiente
Framework - Framework (Linha Datasul) - Oracle - Todas as versões
Causa
O Client Progress OpenEdge não conseguiu localizar o diretório de instalação do Client Oracle. A seguir as possíveis causas: 1. Client Oracle não está instalado; 2. Client Progress OpenEdge não consegue localizar o Client Oracle; 3. Client Oracle é de uma plataforma diferente do Cliente Progress OpenEdge.
Solução
Seguem as soluções de acordo com as causas listadas, respectivamente:
1. Instalar o Client Oracle, observando a plataforma do Client Progress OpenEdge;
2. Configurar a variável de ambiente Path, incluindo o diretório bin do Client Oracle, onde reside o arquivo oci.dll;
3. Quando o Client Progress OpenEdge é 32 bits, o Client Oracle deve ser também 32 bits. Se o Client do Progress OpenEdge é 64 bits, o Client Oracle deve ser também 64 bits.
0 Comentários