FAQs - Suporte técnico

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Erro na Chamada do Processo - MATA216 (Refaz Poder de Terceiros)

 

Ocorrência
No módulo Estoque/Custos, ao tentar utilizar a rotina Refaz Poder de Terceiros, apresenta a mensagem "Erro na Chamada de Processo"

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa
Esta mensagem é exibida na tela quando utilizamos "Stored Procedure" e por algum motivo a mesma gera uma inconsistência em sua execução.

Solução

Antes de seguirmos com as alternativas, é importante certificar-se de que a base esteja atualizada. Desta forma, para atualizar o pacote acumulado do Estoque/Custos, selecione a sua release e clique aqui

Obs: Sempre que aplicar um pacote ou fonte, efetue primeiramente em ambiente de homologação. Em caso de sucesso na aplicação, efetue no ambiente de produção.

 

Partindo da premissa que o acumulado do Estoque/Custos esteja atualizado, siga os passos abaixo:

1° - Através do modulo "Configurador (SIGACFG)" verifique se o conteúdo do parâmetro MV_CUSTEXC está configurado como "Compartilhado" conforme abaixo.

image2018-2-6_15-21-18.png

 

2° - Abra o arquivo "error.log" e verifique se houve algum incidente no processamento da rotina.

Importante: Antes de executar a rotina habilite a chave "TRACESTACK=1" no seu arquivo appserver.ini (Para informações maiores informações clique aqui).

 

3° - Abra o dbAccess Monitor de seu ambiente e execute os procedimentos abaixo:

      • Abra o dbAccess Monitor, clique na aba "Mensagem" e aperte o botão "LIMPAR";

http://tdn.totvs.com/download/attachments/336403860/image2018-2-6_15-25-52.png?version=1&modificationDate=1517937952000&api=v2

      • Execute a Rotina de Refaz Poder de Terceiros (MATA216) e deixe a mensagem "Erro na Chamada do Processo" ser exibida na tela. Retorne ao dbAccess Monitor e verifique na aba mensagem a existência de algum texto de não-conformidade gerado pela rotina, caso exista solicite apoio a sua equipe de Tecnologia da Informação para avaliação.

 - Via SIGACFG:

  • Desinstale a Stored Procedure 15 via configurador.
  • Faça um backup e delete a Stored Procedure 15 da pasta \SYSTEM.
  • Reinicie o TOPConnect.
  • Cole a Stored Procedure 15 na pasta \SYSTEM.
  • Instale a Stored Procedure 15 via configurador.

Caso nenhuma destas alternativas resolva, acione a equipe de Suporte Técnico evidenciando cada etapa deste documento e retorne na abertura do ticket os arquivos console.log, console.bak, error.log, appserver.ini, dbconsole.log, dbaccess.log, cópia da tabela SX6 e o inspetor de objetos.

 

Saiba mais:

Clique aqui e veja mais artigos sobre Processamentos no Estoque

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