Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RM - EDU - Erro ao carregar página no login do EducaMobile

Ocorrência
Ao tentar fazer o login no EducaMobile é apresentado erro descrito como Erro ao carrega página.

Ambiente
RM – Educacional – A partir da versão 12.1.x

Causa
O problema de Erro ao carregar pagina ocorre normalmente porque o servidor de host e/ou a porta definidos no Web.Config do EducaMobile estão informados incorretamente ou também o Alias de conexão presente no Web.config, em C:\totvs\CorporeRM\EducaMobile não foi encontrado por estar incorreto.

Solução

Para solução do problema será necessário informar um servidor de host ativo no Web.config do EducaMobile, recomendamos que o servidor de host seja o mesmo responsável pela execução dos Jobs do sistema ou do próprio servidor WEB onde está hospedado o EducaMobile.

<add key="Host" value="Nome do Servidor" />
<add key="Port" value="8050" />
<add key="JobServer3Camadas" value="false" />

Para verificar o host do servidor WEB, deve-se editar o WEB.Config presente em C:\totvs\CorporeRM\Corpore.Net e localizar a TAG <add key="Host" value="localhost" />.

O mesmo valor encontrado deve ser informado no Web.config do EducaMobile, presente em C:\totvs\CorporeRM\EducaMobile.

Acesse o arquivo Web.config do EducaMobile em C:\totvs\CorporeRM\EducaMobile

Encontre as seguintes linhas:

<!--Configurações de Remoting-->
<add key="EnableCompression" value="false" />
<add key="RemoteLoad" value="false" />
<add key="SelfHosted" value="true" />
<add key="Host" value="localhost" />
<add key="Port" value="8050" />
<add key="JobServer3Camadas" value="false" />

Se o ambiente estiver em 3 camadas:

<!--Configurações de Remoting-->
<add key="EnableCompression" value="false" />
<add key="RemoteLoad" value="false" />
<add key="SelfHosted" value="true" />
<add key="Host" value="Nome ou IP do Servidor de Host" />
<add key="Port" value="8050" />
<add key="JobServer3Camadas" value="True" />

Altere a Porta para 8050

<add key="Port" value="8050" />

Valide se o responsável por executar o Host é a máquina local. Caso não seja informe o nome da máquina na linha:

<add key="Host" value="localhost" />

Valide se no servidor de Host(Responsável pela execução dos processos no sistema), a porta informada também é a 8050, caso não seja, informe na tag do Web.config do EducaMobile <add key="Port" value="8050" /> qual é a porta correta, conforme o servidor de Host.

Ainda no Web.config do EducaMobile Encontre as seguintes linhas:

<!-- Alias para conexão dos serviços -->
<add key="ServiceAlias" value="CorporeRM" />

O CorporeRM deve ser o Alias utilizado para conexão do Portal no arquivo Alias.dat presente no RM.Net do Servidor de Host C:\totvs\CorporeRM\RM.Net\Alias.dat. O nome do Alias deve ser o mesmo informado na tag de conexão acima.

Obs: Valide se não existe espaço no nome do Alias e se o mesmo está apontando corretamente para o servidor desejado.

Importante: As versões da BibliotecaRM e EducaMobile devem estar iguais.

Exemplo: Se a versão da BibliotecaRM for 12.1.23.165, obrigatoriamente a versão do EducaMobile também deve ser a 12.1.23.165. Pois caso estejam diferentes, o erro ao carregar página será exibido.

Após realizar as configurações, tente logar novamente o EducaMobile.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _