Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Erro "type mismatch on compare on CN120GRVPED ou "type mismatch on compare on CN121GERDOC" No encerramento da medição


Ocorrência
No encerramento da medição ocorre o erro de "type mismatch on compare on CN120GRVPED" ou "type mismatch on compare on CN121GERDOC"

Ambiente
Microsiga Protheus – Gestão de contratos – A partir da versão 12 

Causa

Esse incidente ocorre, pois o "Tipo" do parâmetro no dicionário SX6 ou conteúdo MV_CNDPCAL estão diferentes do padrão.

No arquivo de error.log completo da ocorrência pode ser verificada a variável "NGCTDPCAL" com um tipo diferente de "numérico" que é o padrão do sistema (no caso do exemplo da imagem abaixo está como "C" de "Caracter"):

 

 

Solução

Para solucionar essa ocorrência, realize os seguintes passos:
1. É necessário que seja alterado o "Tipo" do parâmetro para "Tipo "Numérico" (na tabela SX6, campo X6_TIPO = N), e deixando o conteúdo como 1, 2 ou 3, conforme a necessidade.

mceclip0.png

 

 

Saiba Mais:

GCT0105- Como corrigir o erro " type mismatch on compare on CN120GRVPED(CNTA120.PRW)"

Artigos Materiais - Gestão de Contratos - (SIGAGCT)

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _