Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Ponto de entrada lj7108 executado diversas vezes

Ocorrência
O ponto de entrada LJ7108 está sendo chamado diversas vezes após o preenchimentos de alguns campos.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.17

Causa
O ponto de entrada LJ7108 é chamado cada vez que um campo tem o seu conteúdo alterado, assim sendo, o preenchimento de um campo, pode disparar diversos gatilhos e a cada alteração o ponto será chamado novamente.

Solução
Para considerar apenas uma chamada do ponto de entrada LJ7108 (em casos de exibição de caixas de diálogo), pode ser criada uma variável estática no fonte que mantenha o controle de exibição.

Exemplo

// BIBLIOTECAS NECESSÁRIAS
#Include "TOTVS.ch"

// VARIÁVEL DE CONTROLE
Static MP_CONTROL As Logical

// ALTERA O CÓDIGO PADRÃO DA TABELA DE PREÇO (MV_TABPAD)
User Function LJ7108()
    Local cTabRet := PARAMIXB[1] // CÓDIGO DA TABELA DE PREÇO (MV_TABPAD)
    Local aPosCpo := PARAMIXB[2] // ITEM PARA VALIDAÇÃO

// VERIFICA SE É A PRIMEIRA EXECUÇÃO
    If (MP_CONTROL == NIL)
// RETORNA A TABELA DESEJADA
    cTabRet := IIf(MsgYesNo("YES=T01 | NO=T02"), "T01", "T02")

// ATRIBUI VALOR LÓGICO
MP_CONTROL := .T.
EndIf
Return (cTabRet)

Saiba mais
MP - Como funciona o parâmetro MV_TABPAD
LJ7108 - Permite alterar o código da tabela de preço (MV_TABPAD)
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _