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Cross Segmento - Backoffice Linha Protheus - ADVPL - Problemas com Integração M.E.S via Execauto MATA650

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência

Utilizo integração M.E.S para inclusão de Ordens de Produção. Quando incluo via rotina manual, a OP aparece automaticamente nas pendencias do M.E.S, porém quando faço o processo via rotina automática a OP não aparece nas pendencias.

Ambiente
Protheus – Manufatura – A partir da versão 12

Causa
Esse incidente ocorre, pois existe uma validação na rotina padrão, a qual avalia a rotina de origem que são permitidas para executar essa integração, essas rotinas são:

"MATA650","MATA651","PCPA111","PCPA110","MATA632","MATA380"
"MATA381","MATA690","MATA712","SFCA310","MATA637","PCPA107"
"PCPA114"


Solução
Para que a integração funcione a partir da rotina automática MATA650, é necessário incluir o parâmetro FUNNAME no comando Prepare Environment.
A preparação de ambiente também pode ser realizada pela função RpcSetEnv informando o parâmetro cFunName.

Prepare Environment
PREPARE ENVIRONMENT EMPRESA "99" FILIAL "01" MODULO 'PCP' FUNNAME 'MATA650'
RpcSetEnv
RPCSetEnv("99" , "01",,,"PCP","MATA650",,,,,)


Saiba Mais:
Prepare Environment.
RpcSetEnv

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1 Comentários

  • Avatar
    Geison Cargnin

    E como tratar caso a rotina esteja dentro de outra rotina de usuário?

     

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Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

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Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

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Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

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Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

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