Ocorrência
No módulo de Estoque, ao tentar realizar o Recálculo do Custo Médio, apresenta a mensagem sobre "Erro na Chamada de Processo". O que fazer para resolver?
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.
Causa
Esta mensagem é exibida na tela quando utilizamos "Stored Procedures" e por algum motivo a Procedure gera uma inconsistência em sua execução.
Solução
Antes de seguirmos com as alternativas, é importante certificar-se de que a base esteja atualizada. Desta forma, para atualizar o pacote acumulado do Estoque/Custos, selecione a sua release e clique aqui
Obs: Sempre que aplicar um pacote ou fonte, efetue primeiramente em ambiente de homologação. Em caso de sucesso na aplicação, efetue no ambiente de produção.
Partindo da premissa que o acumulado do Estoque/Custos esteja atualizado, siga os passos abaixo:
1° - Através do modulo "Configurador (SIGACFG)" verifique se o conteúdo do parâmetro MV_CUSTEXC está configurado como "Compartilhado" conforme abaixo.
2° - Abra o arquivo "error.log" e verifique se houve algum incidente no processamento da rotina.
Importante: Antes de executar a rotina habilite a chave "TRACESTACK=1" no seu arquivo appserver.ini (Para informações maiores informações clique aqui).
3° - Abra o módulo "Configurador (SIGACFG)" e altere a quantidade de threads a serem executadas de forma simultânea através do parâmetro MV_A330THR (altere a quantidade para igual a 1).
Observação: Após a configuração do parâmetro execute a rotina de recalculo do custo médio e verifique se o incidente é reproduzido.
4° - Abra o dbAccess Monitor de seu ambiente e execute os procedimentos abaixo:
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Abra o dbAccess Monitor, clique na aba "Mensagem" e aperte o botão "LIMPAR";
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Execute a rotina "Recalculo do Custo Médio (MATA330)" e deixe a mensagem "Erro na Chamada do Processo" ser exibida na tela. Retorne ao dbAccess Monitor e verifique na aba mensagem a existência de algum texto de não-conformidade gerado pela rotina, caso exista solicite apoio a sua equipe de Tecnologia da Informação para avaliação.
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5° - Via SIGACFG:
- Desinstale a Stored Procedure 19 via configurador.
- Faça um backup e delete a SP 19 da pasta \SYSTEM.
- Reinicie o TOPConnect.
- Cole a SP 19 na pasta \SYSTEM.
- Instale a SP 19 via configurador.
Caso nenhuma destas alternativas resolva, acione a equipe de Suporte Técnico evidenciando cada etapa deste documento e retorne na abertura do ticket os arquivos console.log, console.bak, error.log, appserver.ini, dbconsole.log, dbaccess.log, cópia da tabela SX6 e data dos fontes MATA330 e M330JCTB.
Importante:
Se o Erro em questão for na chamada de processo, sob uma procedure, exemplo:
CALL MAT004_19_01 ('01','N','99','20210101',1,1,2,'0','S','S','98','20210101',9,'0080','1',1,'20210301','1',5,1,'BRA',0,'MANUTENCAO','1','0','0','0',1,'0','0','20210101','0','1','290',' ','0','01') FAILED.
Isso se trata de um erro na chamada de processo, para utilização dos dados gravados da procedure 19, em sua base de dados.
Algum parâmetro ou tipo de movimento, realizado dentro do periodo vigente, esta retornando invalido, fazendo com que a procedure apresente erro durante a sua chamada.
Devera acionar o seu DBA responsável pelo banco de dados, para analisar o problema ocasionado, pois o suporte padrão não atua na base de dados do cliente.
Saiba mais:
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