Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP- Portal Protheus - Erro ao tentar alterar o usuário de portal

Ocorrência

Ao alterar o cadastro de usuário de portal.

Ambiente

Microsiga Protheus - a partir da versão 12.

Causa

O erro gerado é : array out of bounds ( 0 of 0 ) on {|a,b,c| FWInitCpo(a,b,c),xRet:=(IIF(!INCLUI .AND. !EMPTY(ACOLS[LEN(ACOLS)][2]),POSICIONE("SA1",1,XFILIAL("SA1")+AI4->AI4_CODCLI+AI4->AI4_LOJCLI,"A1_NOME"),"")),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }(PROTHEUSFUNCTIONMVC.PRX) 23/10/2018 18:06:52

Este erro ocorre em razão da validação do inicializador padrão (x3_relação) do campo AI4_NOMCLI estar incorreto.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1-Acesse o dicionário de dados via configurador;

2-Selecione a tabela AI4 e altere o x3_relação (inicializador padrão) do campo AI4_NOMCLI:

De: IIF(!INCLUI .AND. !EMPTY(ACOLS[LEN(ACOLS)][2]),POSICIONE("SA1",1,XFILIAL("SA1")+AI4->AI4_CODCLI+AI4->AI4_LOJCLI,"A1_NOME"),"")

Para: IIF(!INCLUI .AND. !EMPTY(AI4->AI4_CODCLI),POSICIONE("SA1",1,XFILIAL("SA1")+AI4->AI4_CODCLI+AI4->AI4_LOJCLI,"A1_NOME"),"")   


Altera__o_da_AI4_Nomcli.gif

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _