Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - MCE - Erro OCX na geração de gráficos

time.png Tempo aproximado para leitura: 00:04:00 min

Ocorrência
Ao abrir programas do estoque com análise de gráficos, como o CE0815 - Consulta Consumo Item, pode ocorrer o erro abaixo:

O controle Activex especificado não é registrado ou o arquivo .ocx foi copiado para outro diretório. Erro ocorreu na procedure: control_load utp/wutapi011.w (6087)

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Estoque (MCE) - Versão 12

Causa
A geração de gráficos nos programas utilizam a rotina utp/wutapi011.w que por sua vez utiliza o OCX chartfx, e neste caso se faz necessário o registro deste componente no Windows.

Solução
Nas estações onde o erro ocorre, será necessário instalar o OCX utilizando um dos arquivos com extensão .bat, existentes no diretório interfac\chartfx do produto.

Exemplo: \\produto>\interfac\chartfx

Importante

  • No diretório interfac\chartfx existem dois arquivos .bat, o regchartfx.bat e o regchartfxnt-2000.bat, cuja diferença é o diretório em que serão registradas as DLLs, que para o primeiro arquivo, é no c:\windows\system32 e para o segundo é o c:\winnt\system, logo, depende do Sistema operacional utilizado.
  • O procedimento deve ser realizado em todas as estações de trabalho.
  • Para que seja feito o registro corretamente, o usuário de rede que efetuar o procedimento deve ser o administrador da máquina.
  • Indicamos que seja feita uma cópia da pasta chartfx para a máquina local, antes de executar o .bat.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _