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WINT - ORA-12170: TNS Ocorreu Timeout da Conexão

Ocorrência
Ao tentar importar um pedido na rotina 2075-Frente de Caixa a mensagem ORA-12170: TNS Ocorreu Timeout da Conexão é apresentada.

Ambiente
Winthor - Mensagem de erro: ORA - Aplicável a partir da versão 29

Causa
O erro ORA-12170 acontece quando o banco de dados não estiver conectado com o WinThor. 

Solução
Para resolver essa mensagem, siga o passo a passo a seguir:

1. Verifique se não há problemas de conexão de rede entre a rotina 2075 - Frente de Caixa e o Banco de Dados;

2. Verifique se a máquina do caixa está conectada na rede ou se existe algum bloqueio de comunicação como firewall ou antivírus,

3. Acesse o diretório C: pasta OracleXe na sua máquina;

4. Dê um duplo clique na pasta tnsnames;

mceclip0.png

5. Analise se o tnsnames está com os dados corretos do banco de produção. Caso não esteja, faça a correção copiando os dados corretos, conforme a imagem meramente ilustrativa, e cole no seu banco de produção;

6. Refaça novamente o processo desejado. 

 

Importante
Imagens meramente ilustrativa, porque cada empresa apresenta dados de produção específicos.

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