Ocorrência
Ao realizar um cancelamento de um Teleatendimento, é gerado o seguinte error log:
array out of bounds ( 0 of 11 ) on TK503ADELOK(TMKA503A.PRW) 02/06/2017 09:46:05 line : 2072
Ambiente
Cross Segmentos-TOTVS Backoffice (Linha Protheus)- SIGATMK- a partir da versão 11.80.
Causa
O erro de array out of bounds ocorre quando o campo não existe no banco ou no dicionário de dados, quando não está como usado ou teve seu nível de campo alterado.
O sistema está requerendo dentro do array, o campo ADF_CODSUQ e não está encontrando.
Solução
Para solucionar essas ocorrências, realize os seguintes passos:
1. Verifique se o campo existe na tabela SX3;
2. Verifique se o campo existe dentro da tabela ADF;
3. Verifique se via configurador, se o campo está em uso e com o nível igual a 1;
4. Após as verificações e ajustes, reinicie o smartclient e refaça o processo de cancelamento.
0 Comentários