Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos-TOTVS Backoffice (Linha Protheus)- SIGATMK-array out of bounds ( 0 of 11 ) on TK503ADELOK(TMKA503A.PRW)

Ocorrência

Ao realizar um cancelamento de um Teleatendimento, é gerado o seguinte error log: 

array out of bounds ( 0 of 11 ) on TK503ADELOK(TMKA503A.PRW) 02/06/2017 09:46:05 line : 2072

 

Ambiente

Cross Segmentos-TOTVS Backoffice (Linha Protheus)- SIGATMK- a partir da versão 11.80.

 

Causa
O erro de array out of bounds ocorre quando o campo não existe no banco ou no dicionário de dados, quando não está como usado ou teve seu nível de campo alterado.

O sistema está requerendo dentro do array, o campo ADF_CODSUQ e não está encontrando.

Solução

Para solucionar essas ocorrências, realize os seguintes passos:

1. Verifique se o campo existe na tabela SX3;

2. Verifique se o campo existe dentro da tabela ADF;

3. Verifique se via configurador, se o campo está em uso e com o nível igual a 1;

4. Após as verificações e ajustes, reinicie o smartclient e refaça o processo de cancelamento.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _