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Ocorrência
Ao tentar enviar uma nota fiscal, o retorno da SEFAZ - Secretaria da Fazenda é a rejeição 539 Duplicidade de NF-e, com diferença na Chave de Acesso ou 241 Um número da faixa já foi utilizado.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Nota Fiscal Eletrônica (NFE) – Todas as versões
Causa
A rejeição significa que já foi transmitida e autorizada uma NFe - Nota Fiscal Eletrônica na base de dados da SEFAZ com o mesmo número, série, modelo e CNPJ - Cadastro Nacional da Pessoa Jurídica do Emitente.
Esta situação ocorre por três motivos:
1. Emitiu uma nota no ambiente de testes do Sistema, mas no programa CD0403B - Configurações do TSS estava configurado para Produção no campo Ambiente SEFAZ, pasta Geral e desta forma a nota foi enviada para o ambiente de produção da SEFAZ. Quando no ambiente de produção do Sistema atinge a mesma numeração que foi gerada indevidamente pela base de teste, ocorre a rejeição, porque a numeração já está na SEFAZ;
2. Alterou de forma indevida o número da nota fiscal no programa FT0114 - Consulta Série x Estabelecimento, campo Ult Nota Emitida. Desta forma, ao gerar uma nova nota fiscal acabou usando um número que já foi enviado para a SEFAZ;
3. Por fim, a situação mais comum é quando possui uma customização ao clicar no botão para efetivar a nota dos programas FT4001 - Cálculo de Embarques; FT4002 - Faturamento de Pedidos; FT4003 - Cálculo de Notas Fiscais ou RE1001 - Manutenção de Documentos, onde é chamada as BO's de Cálculo: o Sistema gera o arquivo XML e envia para o aplicativo de transmissão fazer a primeira validação, que é do schema. Se o XML está correto, o aplicativo de transmissão guarda o XML e envia para o Sistema uma informação que o arquivo está correto. No Sistema é criada a nota fiscal e o aplicativo de transmissão já envia este XML da nota fiscal para a SEFAZ.
Se a customização está cadastrada em um ponto indevido, o processo ocorre corretamente até o envio do XML para o aplicativo de transmissão e o retorno da informação do XML correto para o Sistema. Mas se a customização faz alguma validação de informação e que apresenta algum erro, desfaz a transação e não faz a criação da nota no Sistema, mas o XML já foi enviado para SEFAZ. Ou seja, o XML é enviado para a SEFAZ e a nota fiscal não é criada no Sistema, devido a validação da customização.
Assim, quando emitir a nova nota vai usar a mesma numeração, já que a nota não foi criada no Sistema e não atualiza a numeração no programa FT0114.
Solução
Opção 1 - Verifique se a chave de acesso da nota que está no programa FT0909 - Consulta de Notas Fiscais Eletrônicas no botão Situação está autorizada na SEFAZ. Se estiver, compare se as informações constantes nas notas no Sistema são as mesmas que constam na SEFAZ: mesmo cliente, item, valores etc.
Se for a mesma nota, faça a abertura de um ticket para o Suporte pelo Portal do Cliente, para que seja enviado o procedimento para alterar a situação da nota.
Opção 2 - Se a chave de acesso que está no programa FT0909 não estiver autorizada na SEFAZ e utilizar o aplicativo de transmissão TSS - Totvs Service SOA, verifique no banco do TSS qual a chave de acesso que está autorizada na SEFAZ para essa numeração de nota.
No banco do TSS faça a consulta abaixo:
SELECT NFE_ID,NFE_PROT, STATUS
FROM SPED050
WHERE NFE_ID LIKE 'XXX%'
Substituir o XXX no SQL acima pela chave de acesso da nota fiscal sem os últimos 10 dígitos deixando o caractere % no final.
A chave de acesso que estiver com o campo STATUS = 6, é a chave de acesso dessa numeração de nota que está autorizada na SEFAZ.
Verifique na SEFAZ se a nota que está autorizada é a mesma nota que está no Sistema: cliente, itens, valores etc:
- Se for a mesma nota, faça a abertura de um ticket para o Suporte pelo Portal do Cliente, para que seja enviado o procedimento para alterar a chave de acesso e situação da nota.
- Se forem notas diferentes entre em contato com a Consultoria para fazer o acerto de base dessa nota, alterando a nota no Sistema para que fique igual a nota da SEFAZ.
Para quem utiliza o aplicativo de transmissão TC2.0 - Totvs Colaboração 2.0, verifique no monitor da Neogrid qual a chave de acesso que está autorizada para essa numeração de nota e faça comparação da nota do Datasul com a SEFAZ.
- Se for a mesma nota, faça a abertura de um ticket para o Suporte pelo Portal do Cliente, para que seja enviado o procedimento para alterar a chave de acesso e situação da nota.
- Se for notas diferentes entre em contato com a Consultoria para fazer o acerto de base dessa nota, alterando a nota no Sistema para que fique igual a nota da SEFAZ.
Importante
Se ocorrer a rejeição 204 - Duplicidade de NFe, geralmente essa rejeição indica instabilidade na SEFAZ ou aplicativo de transmissão desatualizado, com isso verifique se a chave de acesso e dados da nota são as mesmas no Datasul e SEFAZ, e entre em contato com o Suporte para corrigir a situação da nota. Caso for notas diferentes, entre em contato com a Consultoria.
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