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Cross Segmentos - Linha Datasul - NFE - Erro de validação da SEFAZ para as notas de entrada informando que não foi possível validar a chave de acesso, mas logo após atualiza de forma correta

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao tentar validar a chave de acesso de uma nota fiscal de entrada, o retorno da SEFAZ - Secretaria da Fazenda é a mensagem Não foi possível validar a chave de acesso NF-e, mas logo após a mensagem a nota fiscal é atualizada de forma correta no Recebimento.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Nota Fiscal Eletrônica (NFE) – Todas as versões

Causa
A mensagem de validação ocorre devido a forma de pesquisa do TSS - TOTVS Service SOA. Abaixo a ordem de pesquisa da chave de acesso pelo TSS:
1. SEFAZ Nacional
2. SEFAZ Origem
3. SVRS - SEFAZ Virtual do Rio Grande do Sul

Solução
Não é necessário alterar nenhuma parametrização, porque a nota atualiza normalmente.

Quando o TSS não encontra a nota fiscal na SEFAZ Nacional, ocorre a mensagem de validação. Mas logo em seguida a pesquisa é feita na SEFAZ de Origem. Se encontra a nota, valida a chave e retorna a mensagem Nota Fiscal atualizada com êxito.

Por isso aparece a mensagem algumas vezes e logo depois atualiza a nota fiscal.

Nem sempre quando a nota está na SEFAZ de Origem, já está atualizada na SEFAZ Nacional, que é o primeiro ambiente que o TSS faz a consulta.

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Usuários que acharam isso útil: 1 de 2

3 Comentários

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    Gabriela Gaspar Colaviti

    Bom dia,

     

    E quando a nota não é atualizada ? Esse artigo não tem solução nenhuma, precisamos de uma solução para quando o erro se mantém. O que devemos fazer ? 

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    ANDRESSA FERREIRA

    E quando atualiza a nota no CC, CE, AP e não atualiza OF? 

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    TI Leal

    Estou com o mesmo problema. a nota não atualiza, ja faz 5dias

     

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