Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice Linha Protheus - SIGAFIN - FINA181 - Ao resgatar ou visualizar as parcelas apresentando Não foram encontradas parcelas para este contrato

time.pngTempo aproximado para leitura: 00:05:00 min

 

Ocorrência
Nas rotinas FINA171 / FINA181  ao resgatar ou visualizar as parcelas apresentando “Não foram encontradas parcelas para este contrato !”

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Todas as versões

Causa
Caso seja alterado através de uma sintaxe/função/customização a filial, prefixo, número do título e tipo referente aos títulos gerados de um empréstimo na tabela SE2, irá apresentar o erro ao visualizar ou resgatar as parcelas.

Exemplo: Ao efetuar um contrato pela rotina FINA171 Inclusão de Empréstimo com um contrato de número 123456 em 10 vezes.

01_inclusao.jpg

Automaticamente o sistema terá que gerar o mesmo conteúdo no campo E2_NUM contendo o mesmo tamanho e número do contrato gerado pela rotina FINA171 – Inclusão de Empréstimo. A geração dos títulos na rotina FINA050 – Contas a Pagar deverão ser na mesma filial do contrato, possuir o prefixo EMP, o tipo: PR e ao contrário disso ter problema ao visualizar as parcelas ou no momento do resgate.

Segue na imagem abaixo as parcelas geradas corretamente na rotina FINA050 – Contas a Pagar

 02_parcelas_corretas.jpg

Caso esteja utilizando qualquer tipo de sintaxe/função/customização para alterar o conteúdo dos títulos na tabela SE2, seja alteração na filial ou no prefixo ou no número do título ou no tipo irá gerar a inconsistência abaixo:


Exemplo:
Veja que na tela abaixo foi utilizado algum tipo de função (na tabela SX3 no campo E2_NUMgatilho,  user function, fonte customizado para inserir zeros a esquerda do campo número do título, fazendo com que o número gerado na tabela SE2 fique diferente da tabela SEH contrato.

03_parcelas_com_zeros_no_numero.jpg

Com isso ao tentar visualizar as parcelas ou tentar resgatar, irá apresenta a mensagem “Não foram encontradas parcelas para este contrato!”

04_erro_ao_resgatar.jpg

A mesma mensagem “Não foram encontradas parcelas para este contrato!” irá ocorrer caso tiver algum tipo de sintaxe/função/customização que faça com que o sistema altere o campo prefixo fazendo com que fique diferente do prefixo EMP conforme o exemplo abaixo:

05_erro_no_prefixo.jpg

Solução:
Será necessário retirar a sintaxe/função/customização feita através de algum gatilho ou campo da tabela SX3 ou etc... e deixar conforme o padrão do sistema.

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _