Tempo aproximado para leitura: 00:01:30 min
Ocorrência
Ao realizar a instalação do WTA é apresentada a mensagem: WTA já foi instalado no servidor xxxxx.
Ambiente
TOTVS Distribuição Linha Winthor - 0 - Framework - A partir da versão 30
Causa
Essa mensagem ocorre quando consta uma instalação do WTA na sua base de Produção onde os dados do IP não foram limpos via arquivo wta-uninstall de forma automática.
Solução
Para solucionar o problema, siga os passos abaixo:
1. Acesse a rotina 132 - Parâmetros da Presidência, e no campo de pesquisa digite o parâmetro 2851 - IP do Servidor WTA;
2. Limpe o campo e clique Salvar;
3. Faça o mesmo com o parâmetro 2849 - Número da Porta do WTA;
4. Na máquina onde o Winthor Anywhere anterior está instalado, acesse o menu de Serviços do Windows, para isso clique em Iniciar > Executar ou pressionando Windows+R e digite no campo busca services.msc;
5. Procure os serviços, Winthor Anywhere e ActiveMQ Artemis, clique com o botão direito do mouse e selecione Parar Serviço;
6. Ainda na mesma máquina, acesse o diretório C:\pcsist\produtos e execute o arquivo wta-uninstall.bat e aguarde o término da instalação;
7. Quando finalizar a desinstalação pode iniciar a nova instalação do WTA.
0 Comentários