Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAQNC - Falha na numeração sequencial da FNC

time.png Tempo aproximado para leitura: 00:01:40 min

Ocorrência
Ao incluir uma FNC - Ficha de Ocorrência e Não Conformidade é apresentada mensagem de falha no inicializador padrão. Em alguns casos, a sequência é gerada, porém está incorreta. 

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) – Controle de Não Conformidades (SIGAQNC) – Todas as versões

Causa
Esta situação ocorre quando o inicializador padrão está incorreto ou porque as tabelas que controlam a numeração QNSXE e QNSXF não constam no banco de dados.

Solução
Para solucionar esta ocorrência, siga os procedimentos abaixo:
1. No módulo SIGACFG - Configurador, na opção Dicionário de dados, verifique se o inicializador padrão do campo está com a expressão a seguir. Caso não estiver, realize o ajuste, salve e faça um novo teste:

IF(INCLUI,GETQNCNUM("QI2","QI2_FNC",,1,STRZERO(YEAR(DDATABASE),4),@AQNQI2),)  

2. Através do APSDU ou Gerenciador de banco de dados, verifique se as tabelas QNSXE e QNSXF constam em seu banco de dados. Caso não constar, é necessário acessar a pasta .\protheus_data\system do seu servidor, localizar os arquivos QNSXE e QNSXF e importá-los para o seu banco de dados. Após importar estes arquivos, é necessário apagá-los da pasta system.

3. Caso ainda assim a inconsistência com a numeração persistir, abrir ticket com as tabelas QNSXE e QNSXF completas, a data dos fontes QNCXFUN e QNCA040 - Cadastro de Ocorrências/Não-Conformidades e a evidência demonstrando a situação que está ocorrendo.

Importante
Caso deseje que, ao cancelar a tela de inclusão da FNC, o número em questão seja reutilizado para a próxima FNC, configure o parâmetro MV_QNCVSEQ - Define se devera ser recuperado Código Sequencial da Ficha Não-Conformidades e Plano de Ação após um cancelamento ou exclusão como S - Sim.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _