Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - ADVPL - Falha na tentativa de bloquear alias SB2

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Temos um serviço via web service que executa a rotina automática que utiliza a SB2 e quando outro usuário acessa outra rotina que irá alocar a SB2, gerar o erro or log abaixo e trava o serviço.

THREAD ERROR ([XXXX], XXXXXX, THIS) XX/XX/XXXX
Falha na tentativa de bloquear alias SB2, recno213.O registro está sendo usado por outro usuário: XXXX MATA103 - TCPIP - ThreadID(9632) (localhost:4323) on LOCKERRORLOG(APLIB060.PRW) 

Called from LOCKERRORLOG(APLIB060.PRW) 
Called from HELPLOCK(APLIB060.PRW)

Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 11.80

Causa
Foi verificado que o HELPLOCK ocorre quando há concorrência de trava entre usuário A e B a um mesmo registro, onde o tempo em que o registro fica travado pelo usuário A é maior que timeout(tempo de espera) na requisição do usuário B.


Solução
Para evitar a mensagem, será necessário avaliar o tempo médio que o registro fica travado em seus processos, e alterar o timeout no client que requisita o serviço com um tempo condizente. 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _