Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - O campo neste registro que está sendo inserido ou atualizado é muito grande (4212)

relogio.png Tempo aproximado para leitura: 00:03:21 min

Ocorrência
Ao executar alguma rotina no Datasul com Banco de Dados Oracle, é apresentada a mensagem O campo neste registro que está sendo inserido ou atualizado é muito grande (4212).

Ambiente
Framework - Framework (Linha Datasul) - Oracle – Todas as versões

Causa
O tamanho do campo que o programa tentou inserir o registro é inferior do valor da inserção.

Solução
No dataserv.lg é identificado a tabela e o campo que retornou o erro, conforme exemplo:

Campo caracter muito longo; tabela: ems2.CLF_VAR column: DES_VARIAVEL. (2728)

No exemplo acima,  o conteúdo a ser inserido na coluna DES_VARIAVEL da tabela CLF_VAR ultrapassou o limite. Verifique no Banco de Dados o tamanho definido para o campo e faça o acerto duplicando o valor. Exemplo, caso esteja com varchar2(400) execute o comando abaixo para fazer o acerto.

ALTER TABLE CLF_VAR
MODIFY DES_VARIAVEL varchar2 (800);

Feito isso execute novamente o programa para verificar se o problema foi corrigido.

 

 

Saiba mais
Para descobrir qual(is) campo(s) do Oracle precisam ser incrementados, configure o arquivo de log do Dataserv conforme o artigo Framework - Linha Datasul - TEC - Como habilitar o modo debug no Dataserver

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _