FAQs - Suporte técnico

MP - ADVPL - Erro There is no current index. on TRPOSITION:EXECUTE


Ocorrência

Sistema apresenta erro ao criar relatório com TOTVS Report. 

THREAD ERROR ([XXXX], XXXX, XXXXXx) xx/xx/xxxx
AFN010: There is no current index. on TRPOSITION:EXECUTE(REPORT05.PRW)

Called from TRPOSITION:EXECUTE(REPORT05.PRW) 
Called from TRSECTION:EVALPOSITION(REPORT02.PRW) 

Tabela principal é a SD1, tabelas relacionadas SC7 e AFN. 
O relacionamento com a tabela SC7 já é o padrão. 
Criado relacionamento com a tabela AFN, campos D1_DOC+D1_ITEM+D1_COD com os campos AFN_DOC+AFN_ITEM+AFN_COD.


Ambiente
Protheus – ADVPL – A partir da versão 11.80

Causa
Erro ocorre pois a tabela não tem o índice correspondente ao criado no relacionamento 

Solução

Para criação do Índice no Configurador -> Banco de dados -> Tabela 

- click no Ícone de Edição

- Opção Índice e click criar novo índice , correspondente ao seu relacionamento.

- Salvar  em ambiente exclusivo.

 

Exemplo: 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _