Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP-FAT-InterFunctionCall - cannot find function OMSM011NFS in AppMap on MATA461IPG

Ocorrência

Ao faturar o pedido,gera o help: Nofuncw - Problema: Função : OMSM011NFS Calleb By MATA461IPG

 

mceclip0.png

Em alguns caso ao fechar gera o erro: InterFunctionCall: cannot find function OMSM011NFS in AppMap on MATA461IPG(MATA461.PRX) 


Ambiente

Microsiga Protheus -  a partir da versão 12.1.17.

Causa

O erro ocorre, devido a função OMSM011NFS não estar disponível no RPO ou a rotina pai, a qual a função pertence estar desatualizada.


Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1. Efetue o download do OMSM011, rotina pai da função OMSM011NFS, mais atual, conforme sua versão de ambiente: 

12.1.23: https://suporte.totvs.com/portal/p/10098/download?e=740851 

12.1.17: https://suporte.totvs.com/portal/p/10098/download?e=740850

2. Aplique o pacote via TDS ou o antigo IDE, aceitando os fontes mais atualizados;

3. Posteriormente, inicialize o Smartclient e refaça o processo.

OBS: O processo informado acima para ser realizado requer um analista com conhecimentos em estrutura de Protheus. Qualquer dúvida no processo, acione a equipe de Framework.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _