Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Port already in use 4444

time.png Tempo aproximado para leitura: 00:01:40 min

Ocorrência
No arquivo de log do JBoss é encontrado o erro abaixo:

--- MBeans waiting for other MBeans ---
ObjectName: jboss:service=invoker,type=jrmpha
State: FAILED
Reason: java.rmi.server.ExportException: Port already in use: 4444; nested exception is:
java.net.BindException: Address already in use: JVM_Bind
I Depend On:
jboss:service=Naming

--- MBeans waiting for other MBeans ---
ObjectName: jboss:service=invoker,type=jrmpha
State: FAILED
Reason: java.rmi.server.ExportException: Port already in use: 4544; nested exception is:
java.net.BindException: Address already in use: JVM_Bind
I Depend On:
jboss:service=Naming

Ambiente
Framework - Framework (Linha Datasul) - JBoss - Todas as versões

Causa
A porta 4444 está definida em duplicidade no arquivo ports-bindings.xml. Esta porta pode variar de acordo com a porta de acesso da instância, de acordo com a tabela abaixo:
instance-8080: porta 4444
instance-8180: porta 4544 
instance-8280: porta 4644
instance-8380: porta 4744
instance-8480: porta 4844
instance-8580: porta 4944

Solução
Verificar no arquivo ...\ServidorAplicacao\jboss-4.2.3.GA\binding\ports-bindings.xml  as portas que estão em type=jrmpha, pois na mídia de instalação do produto essas portas são configuradas iguais a type=jrmp.

Manter a porta type=jrmp que aparece na mensagem de erro e trocar a porta type=jrmpha para porta que esteja livre no Sistema Operacional.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _