Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - ADVPL - Erro ao Imprimir Browse

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao solicitar a impressão do Browse, de uma determinada rotina gera o erro or log.

Exemplo:

Temos um campo customizado com uma user function que percorre uma tabela e retorno o conteúdo do campo, a user function é executada no inicializador do browse.

Na Rotina FINA040 gera o erro abaixo.

variable does not exist "E1_PARCELA" on TRBREAK:EXECUTE(REPORT07.PRW)



Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 11.80

Causa
Esse erro pode ocorre em qualquer rotina do padrão ou customização, quando é selecionado uma tabela em uma user function, desposicionando área de trabalho do browse.

Solução
Esse erro " variable does not exist "E1_PARCELA" on TRBREAK:EXECUTE(REPORT07.PRW) " é só um exemplo, pois cada rotina é diferente, o sistema tenta acessar o campo "E1_PARCELA" que na sua estrutura está na "SE1", mas como na user function está sendo utilizada "DbSelectArea()" para selecionar uma tabela é necessário restaurar a área de trabalho, usando no inicio GetArea() e no final a RestArea()

#Include 'Protheus.ch'

User Function INFO()
Local aArea := GetArea() // Salva área atual para posterior restauração
// sua customização
DbSelectArea("TMP")

("TMP")->(DbCloseArea())

RestArea(aArea) // Restaura área atual

Return 
Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

1 Comentários

  • Avatar
    Wagner Souza

    Ajudou, obrigado

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _