Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - BI - Erro ao executar Alerta no Datasul BI

time.png Tempo aproximado para leitura: 00:01:32 min

Ocorrência
Alertas criados por determinados usuários do Datasul BI não enviam e-mail.

Ambiente
Framework - Framework (Linha Datasul) – Business Intelligence (BAS) – Todas as versões

Causa
O Alerta do Datasul BI grava um arquivo temporário na diretorio temp do usuário do Windows. Quando o usuário que criou o alerta não tem permissão para acessar esta pasta, os e-mails não são enviados.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Edite o arquivo DatasulLogFile para verificar a mensagem de erro;
2. Verifique no log qual o diretório apresentado para o erro  System.IO.__Error.WinIOError. Segue exemplo:

Executed as user: DATASUL\adm_serv. ...art of the path 
'C:\Documents and Settings\adm_serv\Local Settings\Temp\98jcfoob.tmp'.    
at System.IO.__Error.WinIOError

3. Acesse o diretório apontado no log e realize a liberação de acesso para todos os usuários que criam Alertas.

Saiba Mais
Para o procedimento de criação de Alertas do Datasul BI consulte o artigo Framework - Linha Datasul - BI - Procedimentos para configurar e enviar alertas pelo Datasul BI
Para o procedimento de ativação do arquivo DatasulLogFile consulte o artigo Framework - Linha Datasul - BI - Como ativar o DatasulLogFile

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _