Ocorrência
Ao se deparar com a mensagem Operação Inválida! Favor preencher todos os dados do certificado A1, ao editar/criar alguma filial, verificar as seguintes informações:
Ambiente
TOTVS Distribuição Linha Winthor - 1 - Plano de Voo - A partir da versão 30
Causa
Esse incidente ocorre, pois as informações do Certificado A1 não estão corretas.
Solução
1. Primeiramente verifique se a Filial que está cadastrando emite NFC-e;
2. Se Sim, acesse a aba Auto-Serviço da rotina 535 e preencha as informações da caixa Certificado A1;
3. Se não, apague todas informações da caixa Certificado A1 (Certificado, Senha, Token, Id Token);
4. Para apagar essas informações, clique com botão direto do mouse e selecione a opção Limpar Certificado.
5. Para finalizar, clique o botão Confirmar;
Observação:
As informações acima serão carregadas na frente de caixa (2030 ou 2075) na carga geral da aplicação. Caso não ocorra na carga inicial o processo poderá ser realizado manualmente:
- Rotina 2030
Acione o menu suspendo com botão direito do mouse acesse o menu abaixo preenchendo as opções de configuração:
- Rotina 2075
1. Acesse o caminho da pasta Certificados no caixa (C:\WinThor\Prod\MOD-020\Certificado) e apague o arquivo do certificado criptografado. Exemplo: 273F2009216148F7.pfx;
2. Agora, acesse na pasta MOD-020 o arquivo PCAUX2075.ini e apague a data da ultima carga geral;
3. Salve o arquivo e abra novamente a rotina.
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