Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - BI - Processo de ETL do Datasul BI não é executado quando agendado

time.png Tempo aproximado para leitura: 00:01:08 min

Ocorrência
Em algumas situações em que o processo ETL - Extract Transform Load  é iniciado através de agendamento, o mesmo apresenta erro. Quando executado manualmente o processo executa corretamente. 

Ambiente
Framework - Framework (Linha Datasul) – Business Intelligence (BAS) – Todas as versões

Causa
Normalmente o erro ocorre devido a parametrização do PROPATH que está no arquivo .ini. Os diretórios dos programas devem ser referenciados com o caminho físico das pastas e não como um mapeamento. O serviço do SQL Agent não reconhece os mapeamentos e desta forma não consegue realizar a extração dos dados corretamente por Agendamento.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Edite o arquivo .ini utilizado pelo Datasul BI;
2. No PROPATH, altere as referências aos mapeamentos para caminhos físicos, conforme exemplo:

  • Parametrização incorretaM:\expdtsul2\nome do arquivo.
  • Parametrização correta: \\nomedamáquina\expdtsul2\nome do arquivo.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _