Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - BI - Erro no reprocessamento da OLAP devido a base corrompida

time.png Tempo aproximado para leitura: 00:01:13 min

Ocorrência
No reprocessamento da OLAP - Online Analytical Processing é retornado Errors in the metadata manager. The dimension ID of .... referenced by the ....... cube, does not exist. Errors in the metadata manger...... xxxxxxx.cub.xml.

Ambiente
Framework - Framework (Linha Datasul) – Business Intelligence (BAS) – Todas as versões.

Causa
Esse erro ocorre basicamente por uma corrupção do arquivo .xml que contém a sua definição do Cubo.  Deve-se possivelmente por uma definição de dimensão conflituosa da estrutura do Cubo.

Solução
Para solucionar o erro é necessário interromper o serviço SQL Server Analysis Services. Apagar o arquivo cub.xml,  conforme especificado no erro apresentado.

Depois da exclusão acima, conecte-se na Instância SQL Server Analysis Services do seu ambiente utilizando a ferramenta SQL Server Management Studio, conforme exemplo abaixo:


conexao.jpg

Será necessário recriar o banco do Data Warehouse, conforme procedimento:

  • Efetue um backup do banco DTS_Warehouse;
  • Exclua o banco DTS_Warehouse;
  • Recrie o banco utilizando-se do setup do Datasul BI.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _