Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAQDO - Não foi encontrada a referência para o arquivo na base de dados

time.png Tempo aproximado para leitura: 00:01:40 min

Ocorrência
Ao tentar visualizar um documento é apresentada a mensagem: QDCDOCERR - Não foi encontrada a referência para o arquivo na base de dados

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Controle de Documentos (SIGAQDO) - Todas as versões

Causa
A mensagem QDCDOCERR é apresentada quando ocorreu perda de vínculo do arquivo do documento armazenado no diretório da instalação do Protheus com o registro localizado na tabela QDH - Documentos no campo QDH_NOMDOC - Nome do Arquivo Docto.

Solução
Para solucionar este erro, realize os seguintes passos:
1. Abra o APSDU;
2. Abra a tabela QDH e filtre pelo documento em questão, utilizando o campo QDH_DOCTO - Código do Documento;
3. Verifique o conteúdo do campo QDH_NOMDOC do documento filtrado no passo anterior;
4. Busque por este arquivo no diretório de armazenamento de arquivos no servidor. Este diretório fica abaixo da pasta protheus_data. Para verificar o diretório completo, verifique o conteúdo do parâmetro MV_QPATHW - Define o diretorio onde contem os arquivos dos Documentos;
5. Caso confirmado que o arquivo não está na pasta, será necessário recuperá-lo e colocá-lo na pasta novamente. Em geral este tipo de situação ocorre devido à alguma manutenção no servidor ou reversão do backup. Esta análise deverá ser realizada pelo administrador do servidor, com base nas últimas alterações feitas antes do erro ser apresentado para os usuários. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _