Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS Educacional - Gestão bibliotecária - BIB - WebService para Renovação de Empréstimos

Ocorrência
Ao utilizar o WS BibMovimentacaoWSDevRenCan para renovar empréstimos,  é retornada a mensagem de erro Publicação ou exemplar não foram encontrados.

mceclip0.png

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
<s:Body>
<s:Fault>
<faultcode xmlns:a="http://schemas.microsoft.com/net/2005/12/windowscommunicationfoundation/dispatcher">a:InternalServiceFault</faultcode>
<faultstring xml:lang="pt-BR">Ocorreu um erro ao efetuar a leitura do registro:
Publicação ou exemplar não foram encontrados.</faultstring>
<detail>
<ExceptionDetail xmlns="http://schemas.datacontract.org/2004/07/System.ServiceModel" xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
<HelpLink i:nil="true"/>
<InnerException i:nil="true"/>
<Message>Ocorreu um erro ao efetuar a leitura do registro:
Publicação ou exemplar não foram encontrados.</Message>
<StackTrace>at RM.Con.Conector.Service.Conector.wsDataServer.ReadRecord(String DataServerName, String PrimaryKey, String Contexto)
at SyncInvokeReadRecord(Object , Object[] , Object[] )
at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]&amp; outputs)
at RM.Lib.Server.AllowAnonymousAttribute.Invoke(Object instance, Object[] inputs, Object[]&amp; outputs)
at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc&amp; rpc)
at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc&amp; rpc)
at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)</StackTrace>
<Type>System.Exception</Type>
</ExceptionDetail>
</detail>
</s:Fault>
</s:Body>
</s:Envelope>

Ambiente
TOTVS Educacional(Linha RM) - Gestão Bibliotecária - A partir da versão 12.1.20

Causa
Esse incidente pode ocorrer, por ausência de informações do contexto. Para utilização de Webservices do Gestão Bibliotecária o contexto precisa ser:

<tot:Contexto>CODCOLIGADA=1;CODFILIAL=1;CODUNIDADEBIB=5;CODSISTEMA='L'</tot:Contexto>

 mceclip1.png

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
Utilizar a ferramenta SoapUI o para leitura do Dataserver, com a função ReadRecord

mceclip2.png

1 - DataServerName: BibMovimentacaoWSDevRenCan

2 - PrimaryKey: R;5559;739;2000017;709

Tipo da operação R , código do empréstimo 5559, código do usuário 739, código da publicação 2000017 e código do exemplar 709.

3 - Contexto: CODCOLIGADA=1;CODFILIAL=1;CODUNIDADEBIB=5;CODSISTEMA='L'

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:tot="http://www.totvs.com/">
<soapenv:Header/>
<soapenv:Body>
<tot:ReadRecord>
<!--Optional:-->
<tot:DataServerName>BibMovimentacaoWSDevRenCan</tot:DataServerName>
<!--Optional:-->
<tot:PrimaryKey>R;5559;739;2000017;709</tot:PrimaryKey>
<!--Optional:-->
<tot:Contexto>CODCOLIGADA=1;CODFILIAL=1;CODUNIDADEBIB=5;CODSISTEMA='L'</tot:Contexto>
</tot:ReadRecord>
</soapenv:Body>
</soapenv:Envelope>

Retorno esperado: 

mceclip3.png

Função Saverecord 

mceclip4.png

mceclip5.png

<![CDATA[<NewDataSet>
<DEVRENCAN>
<TIPOMOVIMENTACAO>R</TIPOMOVIMENTACAO>
<CODCOLIGADA>1</CODCOLIGADA>
<RENOVACAO>false</RENOVACAO>
<CODIGO>5559</CODIGO>
<RESERVADO>Não</RESERVADO>
<CODPUBLIC>2000017</CODPUBLIC>
<CODEXEMPLAR>709</CODEXEMPLAR>
<CODFILIAL>1</CODFILIAL>
<CODUNIDADE>5</CODUNIDADE>
<TITULO>EVIDENCIA</TITULO>
<DATAEMPRESTIMO>2019-06-17T11:12:28</DATAEMPRESTIMO>
<NUMTOMBO>789</NUMTOMBO>
<ANO />
<EDICAO />
<TIPOPUBLICACAO>Livro</TIPOPUBLICACAO>
<DATADEVOLUCAOPREVISTA>2019-06-24T11:12:28</DATADEVOLUCAOPREVISTA>
<DATADEVOLUCAOEFETIVA>0001-01-01T00:00:00</DATADEVOLUCAOEFETIVA>
<CODCLIENTE>739</CODCLIENTE>
<CODPESSOA>3010</CODPESSOA>
<NOMEUSUARIO>ALEXANDRE ÁVILA ARMINDO</NOMEUSUARIO>
<PODERENOVAR>true</PODERENOVAR>
<RENOVAREMPRESTIMO>false</RENOVAREMPRESTIMO>
<BLOQUEAREMPRESTIMOATRASADO>false</BLOQUEAREMPRESTIMOATRASADO>
<CANCELAREMPRESTIMO>false</CANCELAREMPRESTIMO>
<DESCTIPOUSUARIO>Normal</DESCTIPOUSUARIO>
<STATUSEMPRESTIMO>Emprestado</STATUSEMPRESTIMO>
<VALOREMPRESTIMO>0.0000</VALOREMPRESTIMO>
<TIPOPRAZO>Dias</TIPOPRAZO>
<DIAHORAATRASO>(D) 0</DIAHORAATRASO>
<VALORTOTALMULTA>0.0000</VALORTOTALMULTA>
<VALORTOTALMULTAAGRUP>0</VALORTOTALMULTAAGRUP>
<VALORMULTA>1.0000</VALORMULTA>
<VALORABONOMULTA>0</VALORABONOMULTA>
<VALORDESCONTOMULTA>0</VALORDESCONTOMULTA>
<VALORTOTALEMPRESTIMO>0.0000</VALORTOTALEMPRESTIMO>
<SUSPENSAOUSODIA>0</SUSPENSAOUSODIA>
<TOTALDIASSUSPENSAO>0</TOTALDIASSUSPENSAO>
<EXEMPLARBLOQUEADO>F</EXEMPLARBLOQUEADO>
<CONSULTAEXTERNA>false</CONSULTAEXTERNA>
<CODCLIENTEFORNECEDOR>C01454</CODCLIENTEFORNECEDOR>
<CODCOLIGADACLIENTEFORNECEDOR>1</CODCOLIGADACLIENTEFORNECEDOR>
<IDLAN>0</IDLAN>
<IMPRESSO>false</IMPRESSO>
<ISFASCICULO>false</ISFASCICULO>
<QTDRENOVACAOSIST>0</QTDRENOVACAOSIST>
<FLAGGEROULANCAMENTO>false</FLAGGEROULANCAMENTO>
<CODEMPRESTIMOHISTORICO />
<EXIBIRSITUACAODEV>T</EXIBIRSITUACAODEV>
<INFOADICIONAISEXEMPLAR />
<SITUACAOEXEMPLAR />
<ISALUNOCLASSISES>false</ISALUNOCLASSISES>
<SERVICO>0</SERVICO>
<PARCELA>0</PARCELA>
<COTA>0</COTA>
<VALOREMPRESTIMOBOLETOCLASSIS>0</VALOREMPRESTIMOBOLETOCLASSIS>
<CODTIPOUSUARIO>1</CODTIPOUSUARIO>
<CODEMPRESTIMO>5559</CODEMPRESTIMO>
<CODEMPRESTIMOPRINCIPAL>0</CODEMPRESTIMOPRINCIPAL>
<CODAUXILIAR />
<RESPONSAVEL>mestre</RESPONSAVEL>
<NOMEFILIAL>TOTVS - Filial Belo Horizonte</NOMEFILIAL>
<NOMEUNIDADE>ALFA CENTER</NOMEUNIDADE>
<GRUPOPUBLICACAO>Acadêmico</GRUPOPUBLICACAO>
</DEVRENCAN>
</NewDataSet>]]>

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _