Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Insufficient Memory em conexão JDBC

time.png Tempo aproximado para leitura: 00:00:40 min

Ocorrência
Na tentativa de inserir registros no banco emsdev, durante a execução da inicialização do Datasul ou após a execução do importacaobyyou.bat, é retornado o erro [DataDirect][OpenEdge JDBC Driver][OpenEdge] Insufficient Memory.

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge - Todas as versões

Causa
Esse incidente ocorre com a versão do Java diferente e/ou banco de dados emsdev com um valor de segmento de Shared Memory baixo.

Solução
Há duas opções possíveis para que o erro seja contornado:

1. Quando utilizado Java 64-bit, executar com Java 32-bits;
2. O banco emsdev pode ter sido carregado com um valor de segmento de Shared Memory pequeno. Ao aumentar o tamanho para 2GB, utilizando o código abaixo o erro não ocorre:

proserve emsdev -B 5000 -spin 4000 -L 200000 -Mm 4096 -N tcp -S 23624 -n 101 -Ma 15 -Mn 9 -Mpb 4 -shmsegsize 2g

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _