Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

LG - TEC - Ferramenta TotvsPrinter não encontrada

time.png Tempo aproximado para leitura: 00:00:58 min

Ocorrência
Ao gerar relatórios no Logix 12 é apresentada a mensagem Ferramenta TotvsPrinter não encontrada em caminho

Ambiente
Logix – Impressão – A partir da versão 12.1.14

Causa
No Logix 12 é utilizada a ferramenta TotvsPrinter para a geração de relatórios. Esta ferramenta deve existir na pasta tools que fica abaixo do ROOTPATH do ambiente Logix utilizado, exemplo:

[LGXHOMOLOG]
ROOTPATH=D:\totvs\logix

Considerando o ROOTPATH acima, a pasta tools deverá existir dentro da pasta D:\totvs\logix. A ferramenta TotvsPrinter foi incluída no produto através do pacote de atualização da versão 12.1.14

Solução
Copiar o arquivo totvsprinter.exe para dentro da pasta tools, e depois, repetir o processo de geração de relatório a partir do programa no Logix - não é necessário reiniciar o servidor de aplicação.

Importante
Para os casos onde o SmartClient é compartilhado via atalho da rede, como por exemplo \\servidor\logix\smartclient, será necessário copiar manualmente o arquivo totvsprinter.exe para dentro da pasta do SmartClient que está sendo compartilhado.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _