Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Problemas ao utilizar o PE FA100GET (MF100GRV1e MF100GRV4)

time.pngTempo aproximado para leitura:00:02:00 min

Ocorrência

No módulo Financeiro, ao confirmar Movimento Bancário (FINA100), na opção de transferência entre contas  utilizando o ponto de entrada FA100GET o sistema apresenta mensagem (MF100GRV1e MF100GRV4

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – Financeiro – A partir da versão 12

Causa
Esse incidente ocorre, pois o campo E5_MOEDA, na versão 11, tinha tamanho de 3 caracteres, e na versão 12 o campo é de tamanho 2

Solução
Para solucionar essa ocorrência, utilize o exemplo abaixo.

#include "rwmake.ch" 
User function FA100Get ()

Local aTeste :={}
Aadd( aTeste, {"341" })// BANCO ORIGEM
Aadd( aTeste, {"22 " })// AGENCIA ORIGEM
Aadd( aTeste, {"000001 " })// CONTA ORIGEM
Aadd( aTeste, {"0000000001" })// NATUREZA ORIGEM
Aadd( aTeste, {"237" })// BANCO DESTINO
Aadd( aTeste, {"0002 " })// AGENCIA DESTINO
Aadd( aTeste, {"000002 " })// CONTA DESTINO
Aadd( aTeste, {"0000000001" })// NATUREZA DESTINO
Aadd( aTeste, {"CH" })// TIPO MOV ----------- Neste campo que houve a alteração.
Aadd( aTeste, {"999 " })// NUMERO DOC
Aadd( aTeste, {1000 })// VALOR
Aadd( aTeste, {"TESTE " })// HISTORICO
Aadd( aTeste, {"OSASCO " })//BENEFICIARIO

Return aTeste
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

1 Comentários

  • Avatar
    DANIEL DELFINI CORREA

    Bom dia,

    Por favor, mudou algo no tratamento deste array que deve ser retornado pelo ponto de entrada em questão ? Porque se usarmos exatamente este exemplo acima, ao digitarmos ou sairmos do campo  NUMERO DOC, apresenta o error log:


    THREAD ERROR ([3484], ddcor888, C989090) 14/08/2020 09:32:32
    argument #0 error, expected C->A, function substr on FA100DOC(FINA100.PRX) 05/06/2020 14:17:29 line : 6135

    Não funciona com o exemplo acima.

    Obg. Aguardo.

    Daniel

     

     

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _