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Ocorrência
No módulo Caixa e Bancos ao importar arquivo de extrato bancário ocorre a mensagem 12611 – Já existe um extrato com esta referência!
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Caixa e Bancos (CMG) - Versão 12
Causa
Na importação de extrato bancário prgfin\cmg\cmg704aa.r existem duas opções que consistem a importação para não haver duplicidade de dados, essas opções são apresentadas após acionar o botão Executar Lista no programa de importação de extratos:
A opção Valida Data, verifica se não existe um outro extrato já importado em uma data que compreende a data do extrato que está sendo importado. Exemplo: foi importado o extrato com data de 01/10/2007 até 05/10/2007, se for importado um novo extrato com data de 05/10/2007 até 06/10/2007, será exibida uma mensagem de validação, isso se a opção estiver marcada, pois os movimentos do dia 05/10/2007, podem estar sendo importados em duplicidade.
A Opção Valida Referência, verifica se o extrato que está sendo importado já não foi importado anteriormente. Exemplo: quando o extrato é importado é gravada no extrato do Sistema uma referência Referência Extrato que é o nome do arquivo que está sendo importado, portanto caso o mesmo seja importado novamente e a opção Valida Referência estiver marcada será verificado se aquele arquivo já foi importado anteriormente validação pelo nome do arquivo.
Se os campos não forem marcados a verificação não ocorre e o arquivo é importado.
Solução
Deve ser acessado o programa de Manutenção Extratos Conta Corrente, prgfin/cmg/cmg705aa.r. Neste programa deve-se verificar se o arquivo de extrato já está cadastrado, neste caso, constata-se que o mesmo estava sendo importado uma segunda vez:
- Opção Valida Data marcada:
Clicar no botão Faixa e na faixa de referência do extrato campos Data Inicial e até digitar a data do arquivo que está sendo importado:
Ao clicar no botão OK, caso já tenha sido importada esta referência a mesma será apresentada no grid da pesquisa. Se aparecer a referência o usuário deve verificar se precisa importar novamente o arquivo ou se este já foi importado corretamente.
2. Opção Valida Referência marcada:
Clicar no botão Faixa e na faixa de referência do extrato campos Refer Extrat inicial e final digitar o nome do arquivo que está sendo importado:
Ao clicar no botão OK, caso já tenha sido importada esta referência a mesma será apresentada no grid da pesquisa. Se aparecer a referência o usuário deve verificar se precisa importar novamente o arquivo ou se este já foi importado corretamente. Se não aparecer a referência no momento da importação está sendo criado dois extratos com a mesma referência. Isto pode ocorrer quando há no arquivo movimentos da conta normal e da conta de investimentos.
Neste caso sugerimos solicitar ao banco que não envie estas informações no arquivo. Clique no link disponível em Saiba mais sobre a importação de movimentos de investimentos.
Saiba mais
Segue link com mais informações: Cross Segmentos - Linha Datasul - CMG - Importação de Extrato Bancário com Movimentos de Investimentos
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