Ocorrência
Ao transmitir algum evento da Reinf e monitorá-lo, não há retorno, permanecendo no status Transmitido/Aguardando.
Ambiente
TAF - A partir da 12.1.25
obs: ambientes anteriores a versão 12.1.25 do TSS não transmitem o Reinf.
Causa
As causas poderão ser diversas. Para uma melhor análise, recomendamos que na abertura de um chamado seja anexado o console.log e o appserver.ini do TSS, após o monitoramento do evento pendente. Entretanto, será abordado abaixo algumas causas do problema:
Solução
- TSS não estar na versão 3.0;
- Certificado Digital vencido ou não configurado na Wizard TSS do TAF;
- Falta de atualização das URLs do TSS;
- Appserver.ini com alguma inconsistência.
- Evento em Processamento.
- Monitoramento dos eventos sendo feita fora da matriz onde foi transmitida.
A primeira coisa a analisar, é verificar como está o STATUS do evento transmitido na tabela SPED500. Para acessar a tabela SPED500, abra o Smartclient do TSS. (pasta de instalação do TSS bin/smartclient/smartclient.exe). Siga o caminho abaixo:
Existe algumas possíveis situações:
Quando o evento foi transmitido, não é identificado no portal da Receita por estar com os status: Status 2 ou 4 - Evento Recebido.
Quando o evento foi transmitido, é identificado no portal da Receita mas não retornou para o TAF: Status 3, 5 ou 6 - Inconsistente, Rejeitado ou Autorizado.
Caso os eventos estiverem com status 2 ou 4, avalie a parte 1 do artigo. Caso os eventos estejam como 3, 5 ou 6, avalie a parte 2 do artigo.
Parte 1 - Status 2 ou 4
1. TSS na versão 3.0.
Caso o TSS não esteja na versão 3.0, não será possível transmitir e/ou Receber o retorno dos Eventos.
Verifique no artigo abaixo:
TAF - REINF- Como identificar se o TSS está habilitado para utilizar a Reinf
2. Certificado Digital vencido ou não configurado na Wizard TSS do TAF.
Para que a transmissão e o retorno ocorram sem problemas, o certificado digital deverá ser configurado conforme abaixo:
Certificado A1: TAF - ESOCIAL/REINF- Como configurar o certificado digital modelo A1
Certificado A3: TSS - Certificado A3
3. Falta de Atualização das URLs do TSS.
Geralmente, quando há problema referente a URL de transmissão, no console.log do TSS é gerado um erro com a seguinte estrutura:
WSCERRXXX - Retorno VAZIO de POST - (URL utilizada) - Http 404 Not Found
Para correção, é necessário atualizar as URLs conforme artigo abaixo:
TSS - Atualização das URLs do TSS
4. Appserver.ini com alguma inconsistência.
Caso o Appserver.ini do TSS esteja com alguma inconsistência - Jobs comentados, falta de alguma seção obrigatória - a transmissão poderá ser comprometida. Os itens principais a se avaliar:
Seção [SPED]
JOBS - não podem estar comentados ou inexistentes. A configuração da linha INSTANCES irá depender de cada ambiente, mas o formato precisa estar dessa maneira: Instances= n, n, n, n. Para mais informações sobre essa linha, verifique: https://tdn.totvs.com/display/tec/Instances
Segue artigo explicativo sobre os JOBS: TSS - Funcionalidades dos JOBs do TSS 3.0
Seção [ONSTART] - os JOBS acima precisam estar na linha JOBS e a linha REFRESHRATE também é obrigatória, caso apague ou comente essas linhas o TSS não irá transmitir os eventos.
Seção [SSLCONFIGURE] - Obrigatório os itens SSL2, SSL3, TLS1_0, TLS_1 e TLS_2 estarem conforme abaixo.
5.Evento em Processamento
Se o evento sem retorno tratar-se do R-2099 e o mesmo estiver como "Em processamento", avalie o link a seguir: R-2099 Em Processamento
5.Bloqueio da URL de transmissão da RFB.
Foi alterada a URL de transmissão da RFB, ambiente com alta proteção de firewall deve realizar o desbloqueio da URL para envio e retorno das informações.
Copie a URL abaixo no seu navegador e caso retorne com erro realize o desbloqueio da URL:
Parte 2 - Status 3, 5 ou 6
Neste caso, o TSS está falhando em retornar para o TAF os eventos.
1. Avaliar a URL na Wizard do TSS.
Uma das causas deste problema é o ambiente TAF estar apontando para um TSS, sendo que o TSS ativo é outro; isso geralmente ocorre quando há duas ou mais instalações do TSS.
Neste caso, avalie se o endereço e a porta estão corretos.
2. Erros no Console.log.
Caso esteja ocorrendo erros no Console do TSS, realize a abertura de um chamado Junto a Equipe TOTVS anexando o Console.log para análise.
3. Monitoramento dos eventos sendo feita fora da matriz onde foi transmitida.
Supondo que haja duas empresas, 01 e 02. Se a transmissão de um evento foi feito pela matriz 0101, o monitoramento precisa ser realizado acessando o ambiente pela matriz 0101, caso contrário, o monitoramento não será realizado.
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