Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - APB - Leitura de Código de Barras

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao efetuar a leitura do código de barras no Contas a Pagar no botão Cod Barra das rotinas de alteração e pagamento de títulos o mesmo fica com a numeração incorreta.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) – Contas a Pagar (APB) – Versão 12

Causa
Este problema ocorre, pois a leitora de código de barras não está parametrizada com o padrão aceito pelo Contas a Pagar.
As leitoras atuais vem parametrizadas para trazer na leitura a linha digitável do código de barras do boleto, que é a numeração que visualizamos no boleto, ou seja, a leitura do código de barras já vem com os dígitos verificadores.

cod_barras.jpg

Linha 1: nesta linha a leitora deve trazer o código de barras sem os dígitos verificadores. São 44 posições para o boleto normal de cobrança ou 47 posições para o boleto de fatura de consumo água, luz, etc.

Linha 2: nesta linha o programa gera a linha digitável do código de barras para o boleto normal de cobrança de forma automática a partir do código de barras da linha 1. Serão 47 posições: 44 do código de barras mais 3 dígitos verificadores.

Linha 3
: nesta linha o programa gera a linha digitável do código de barras para o boleto de fatura de consumo de forma automática a partir do código de barras da linha 1. Serão 48 posições: 47 do código de barras mais 1 dígito verificador.

Se na linha 1 já estiver vindo a linha digitável do código de barras 47 posições para boleto normal e 48 para fatura de consumo o Contas a Pagar irá gerar novamente os dígitos verificadores incorretamente.

Solução
Para que o código de barras fique correto a leitora deve ser parametrizada para trazer na leitura o código de barras sem os dígitos verificadores, ou seja, não deve trazer na leitura a linha digitável do código de barras, não existe parametrização para isto no Contas a Pagar

A parametrização da leitora de código de barras é de responsabilidade do cliente, não efetuamos a parametrização da mesma no suporte. Caso hajam dúvidas orientamos a entrar em contato com o fornecedor da leitora.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _