Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Erro quantidade de dias de afastamento maior que 365 ou negativo no cabeçalho da RAIS


Ocorrência

Sistema demonstra uma quantidade de dias de afastamento maior que 365 dias ou negativo no cabeçalho da RAIS, rotina manutenção arquivo (GPEM510).

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal – A partir da versão 11

Causa
Esse erro pode ser gerado por uma falha na migração dos dados de afastamento ou atualização incorreta dos dias pagos na rotina de lançamentos/ ausência.

Solução
1. Verifique na tabela SR8 se estas matrículas para os quais constam o erro, estão com os campos:
-R8_DIASEMP ou R8_DPAGOS com valores maiores que 15 dias. Estes campos não podem conter mais do que 15 dias. Necessário solicitar ao departamento pessoal a quantidade dias que a empresa deveria pagar e a quantidade de dias foram pagos efetivamente na folha do funcionário. Se o afastamento for maior que 15 dias, deve ser avaliado se é continuação de algum outro, para entender se estes campos devem estar preenchidos com 15, zerados ou com outra quantidade.

Só precisam ser ajustados os afastamentos com campo R8_TIPO igual a O, P, Q, R ou X.

Esse ajuste também pode ser realizado através do RDMAKE UPDDPGSR8:
Doc.: https://tdn.totvs.com/display/public/PROT/DRHGCH-9769+-+Ajuste+campo+R8_DPAGOS+com+valor+negativo


2. Acessar a tabela SX1 desta empresa em questão, filtrar no grupo de perguntas "GPM510", esses são os parâmetros da RAIS. O correto é ter apenas 1 pergunta neste campo, caso seu filtro retorne mais de uma pergunta, delete uma delas.

3. Depois das correções acima, deve ser efetuada novamente a Geração dos dados para a RAIS (GPEM500) e depois a geração do Magnético (GPEM530).

No programa da RAIS, o arquivo importado deve ser excluído e importado novamente para não gerar duplicidade de informações.

Saiba Mais
Para mais informações acesse o link a seguir: http://tdn.totvs.com/x/DpjHEw

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _