Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Ao acessar a rotina Reajuste de Saldos (CNTA320), ocorre error log - array out of bounds ( 1 of 0 ) on PERGUNTE(MSLIB.PRW)



Ocorrência
Ao acessar a rotina Reajuste de Saldos (CNTA320), ocorre error log - array out of bounds ( 1 of 0 ) on PERGUNTE(MSLIB.PRW)


Ambiente

Microsiga Protheus – Gestão de Contratos – A partir da versão 12

Causa

Esse incidente ocorre, pois , os perguntes da rotina não foram incluídos no sistema , ou está faltando alguma informação nos perguntes.

Solução

1.  Cadastrar os perguntes da rotina segue 

1.Criação de Perguntas no arquivo SX1 – Cadastro de Perguntes:

Pergunte

Contrato de?

Grupo

CNTA320 

Ordem

01

Tipo

Caracter

Tamanho

15

Help Informe o contrato inicial para reajuste dos saldos.
Consulta Padrão CN9 - Contratos

 

Pergunte

Contrato Ate?

Grupo

CNTA320 

Ordem

01

Tipo

Caracter

Tamanho

15

Help Informe o contrato final para reajuste dos saldos.
Consulta Padrão CN9 - Contratos

 

2.  No Configurador (SIGACFG), acesse Ambientes/Cadastro/Menu (CFGX013). Informe a nova opção de menu do Gestão de Contratos, conforme instruções a seguir:

Menu

Miscelânea

Submenu

Processamento

Nome da Rotina

Reajuste de Saldos

Programa

CNTA320

Módulo

SIGAGCT

Tipo

Função Protheus

 

3. Em ambos perguntes preencher na coluna X1_GCS  = G




Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _