Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Danfe via WebService

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência
Utilizando o Danfe via WebService não gera pdf e não gera erro.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus)  – ADVPL – A partir da versão 12.1.17

Causa
Em binários anteriores, o sistema tentava efetuar a abertura da interface gráfica, contudo caso não conseguisse, ele gera o erro internamente e prosseguia com o processamento das demais tarefas.

Contudo, este processo poderia gerar travamentos nas rotinas e impossibilitar o prosseguimento das demais operações, retendo uma thread e onerando a operação.

Solução
Com esta proteção, no momento em que ocorrer a tentativa de exibição de um componente gráfico, será gerado o erro fatal ou até não gerando erro via WebService.

Será necessário tratar todas a funcionalidade no Rdmake DanfeII que exibem tela quando executada pelo sistema, funções como RPTStatus, Pergunte e etc...

Saiba mais

Erro: Job theadrs doesn't suport remote/visual components

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

1 Comentários

  • Avatar
    TIAGO MAIA

    Dizer que vai descontinuar é facil, quero ver ajudar a mudar todas as customizações.

    1
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _