Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

MP - TEC - RUPTECTBL - SELECTTAB - RUP_TEC

MP - TEC - RUPTECTBL - SELECTTAB - RUP_TEC

Ocorrência
Ao realizar a migração para a versão 12.1.023 o sistema apresenta o error.log:

THREAD ERROR ([XXXX], XXXXX, XXXXX) 99/99/9999 99:99:99
: Error : 102 (37000) (RC=-1) - [Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near 'FROM'.
( From tMSSQLConnection::GetQueryFile )
Thread ID [9999] User [XXXXX] IO [999] Tables [99] MaxTables [99] Comment [] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/MICROSIGA_MAISTI_12] DBThread [(SPID 55,60)] Started [21/02/2019 08:22:04] IP [192.168.101.24:2012] IDLE [ ] InTransact [ ] Memory [547568] Running [ROP_QUERY] RCV [47827] SND [207156] TCBuild [20180606-20180904] TCVersion [18.1.1.3] ARCH [64] OS [WINDOWS] BUILD [RELEASE]

SELECT 1 FROM on SELECTTAB(RUP_TEC.PRW) 09/01/2019 17:53:26 line : 1245

Called from RUPTECTBL(RUP_TEC.PRW) 09/01/2019 17:53:26 line : 1045


Ambiente
Microsiga Protheus – Gestão de Serviços – A partir da versão 12

Causa
O fonte (RUP_TEC.PRW) realiza uma validação nas tabelas T4B e T49, porém as tabelas não existem no ambiente.

Solução
Para solucionar essa ocorrência, é necessário utilizar o Dicionário de dados atualizado disponível no Portal do Cliente (o qual já contém as tabelas), e depois executar criteriosamente o procedimento oficial de aplicação do UPDDISTR: https://tdn.totvs.com/pages/viewpage.action?pageId=181965468

 Observação: Também é possível validar a criação das tabelas em seu ambiente, tomando como base os arquivos anexos.

Tabelas para comparação em anexo:

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

2 Comentários

  • Avatar
    Wesley Alves Justiniano

    O link dos arquivos anexos para correção do problema não está disponível, o link está quebrado.

    0
    Ações de comentário Permalink
  • Avatar
    Milton Umemura

    Prezados, bom dia.

     

    Foi ajustado e colocado os aquivo em anexo.

     

    Muito obrigado, atenciosamente;

    Suporte Protheus Serviços

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _