Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - TAF - eSocial - Não Periódicos - S-2299 - O valor 'x' informado na tag tpInsc somado ao valor 'x' informado na tag nrInsc é uma chave composta ao enviar o evento de desligamento (S-2299)

Ocorrência:
Ao enviar o evento S-2299 de Desligamento, ocorre o erro:

Erro 1 - O valor '1' informado na tag tpInsc somado ao valor '18323XXXX' informado na tag nrInsc é uma chave composta e a sua combinação não corresponde a nenhum registro do cadastro na base de dados.

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - eSocial - TAF eSocial - Eventos Não periódicos - S-2299 - Todas as versões

Causa:

Gerado com sucesso no RM e enviado ao Taf com sucesso, veja que abaixo estão os eventos de admissão do funcionário e a demissão (evento que gerou o erro):


Após processar na filial 02 é apresentado inconsistência:
 
Certificando que é o evento S-2299
 
 
Erro apresentado, sem justificativa, pois o mesmo ID com a combinação mencionada abaixo para o S-2200 foi aceito no TAF e RET:
 

Solução:
Abaixo exponho um caso de uso, onde você pode se basear para análise em sua base de dados:
01. Tínhamos no SIGAMAT.EMP o Tipo de Inscrição igual a 2 nas duas filiais 
- Foi alterado para 1 nas duas filiais
- As duas tags <tpInsc> do XML a ser integrado estava como 1
02. Tínhamos a tabela C92 do evento S-1005 compartilhada da seguinte maneira: C-C-C
03. Tínhamos a tabela C99 do evento S-1020 compartilhada da seguinte maneira: C-C-C
04. Tínhamos no campo de filial da tabela C92 preenchido com os códigos das filiais, embora o mesmo estivesse compartilhada
- Foi feito um replace nos campos de filial
05. Processado e integrado corretamente
06.O mesmo ficou compartilhado por empresa, e exclusivo por filial. Quando o compartilhamento é por empresa, então é necessário deixar o campo de filial com o código da empresa.

Outras opções de análise:

Opção 01:

E tivemos um cenário onde o mesmo tentava enviar um evento S-2299, que ao tentar integrar dava erro, foi visto que a admissão foi feita na filial 01 e a demissão estava sendo feita na filial 02.

Sendo assim, será necessário gerar um evento S-2206 na nova filial, e enviar ao TAF e Governo. Com isso, ele irá desativar o funcionário da filial 01 e ativar o funcionário na filial 02. Após isto, somente gerar o XML de desligamento.

Opção 02:
  • Olhar campos C1E_ID, C1E_VERSAO, C1E_ATIVO = CR9_ID, CR9_VERSAO, CR9_ATIVO (devem corresponder todos)
  • Ver se na CR9 contém informações duplicadas, exemplo; duas linhas e ambas ativas, sendo que na C1E eu tenho 1 linha de ALTERAÇÃO

 

Opção 03:

Tendo em vista que você enviou um evento S-2200 para o funcionário X, e ele está incluído corretamente no sistema. Você tem uma filial apenas cadastrada no complemento cadastral do TAF, e as de mais estão cadastradas via 'Outras Filiais', isto é, inclusos na tabela CR9. Todas utilizam a mesma raiz de CNPJ.

Então você envia o XML S-1200 e ocorre o erro do título deste artigo. Ao observar a tabela C92, temos um compartilhamento do tipo 'EXCLUSIVO' nos três níveis, com código de filial preenchido.

Para a correta integração, altere o tipo de compartilhamento para compartilhado por empresa.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _