Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - ADVPL - Erro ao compilar função NGRETCPEMP

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência

Erro ao compilar função NGRETCPEMP.

Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão P12.1.17

Causa

Mediante a uma necessidade técnica, foi realizada a retirada de algumas funções das rotinas NGUTIL e MNTUTIL01, pois estas funções não condizem com o padrão de desenvolvimento TOTVS.


Solução
Segue abaixo as orientações
Em casos como fontes específicos/customizados ainda podem ser existir chamadas destas funções. Para estes casos, pode ser apresentado a falta de uma das funções listadas a baixo. Nestes casos deve-se abrir o documento em anexo, buscar a função e realizar a sua compilação no ambiente.

Atenção

Somente deve ser compilada a função que está apresentado inconsistência por sua falta.

Todas as funções são User Function (Funções de Usuário), por este motivo deve ser realizado
a alteração da chamada da função nos fontes específicos, utilizando o "U_" conforme exemplo
a seguir:
Ex. De NGRETX6() para U_NGRETX6()


Saiba mais
MNT0091 Falta de função em fontes específicos

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _