Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Erro chave duplicada no mês 12 com complemento de 13° salário

Ocorrência
Ao tentar realizar o cálculo da folha do mês 12 com o mnemônico P_CCOMP13 ativo para pagamento do complemento de 13° Salário, com um roteiro customizado que utilize a função fGeraverba, é apresentado o error log: DB error (Insert): -37 File: SRC080 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Native Client][SQL Server]Cannot insert duplicate key row in object 'dbo.SRC080' with unique index 'SRC080_UNQ'. INSERT INTO dbo.SRC080(RC_FILIAL,RC_MAT,RC_PD,RC_TIPO1,RC_VALOR,RC_DATA,RC_DTREF,RC_SEMANA,RC_CC,RC_TIPO2,RC_SEQ,RC_VALORBA,RC_PROCES,RC_PERIODO,RC_NUMID,RC_ROTEIR,RC_CODB1T,RC_IDCMPL,R_E_C_N_O_) VALUES ( ?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)

Ambiente
TOTVS RH - TOTVS RH (Linha protheus) – Gestão de Pessoal – A partir da versão 12.1.17

Causa
Incidente ocorre, por falta tratamento em posição na variável cSeq.

Solução
Para solucionar essa ocorrência, analise a customização e ajuste conforme exemplos do documento técnico a seguir: http://tdn.totvs.com/x/HCkcGw

Saiba mais
RH Expedição Contínua

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _